Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #13488

    Alan Duffy
    Participant

    I have both Responsive Lightbox 1.6.9 and Responsive Lightbox – Lightgallery 1.0.0 installed in WordPress 4.6.1.

    When I click I have them set to show when you click an image or gallery in WordPress.

    However when I click an image in the WordPress gallery, BOTH plugins are opening the image. So what happens is there are two overlays and I have to close the first just to show the Lightgallery behind it.

    Can you fix this please?

    Thanks, Alan

    #13489

    Bartosz
    Keymaster

    Hi Alan,
    Most probably you have another lightbox activated by your theme. Can we have a look at your site?

    #13497

    Alan Duffy
    Participant

    Hi Bartosz,

    I deactivated all plugins except your Responsive Lightbox 1.6.9 and Responsive Lightbox – Lightgallery 1.0.0.

    It worked fine then. There was no duplicated window popping up.

    But I need the other plugins, and so I activated them one-by-one and found that when I activated WPBakery Visual Composer Version 4.12.1, the problem came back. So there’s a conflict between the plugins.

    Even though WPBakery Visual Composer does not have a lightbox of its own, it is somehow causing both of your plugins to fire at the same time when it’s activated, hence the problem.

    Is there anyway to stop this, or maybe a quick fix?

    Alan

    #13499

    Bartosz
    Keymaster

    That’s strange – we haven’t been reported any issues with Visual Composer before.

    For now please enable all the plugins you need and provide a link to the site.

    But it would be best if you could give us a temporary FTP and admin access to your site – in order to take a look at things in detail.

    #13508

    Alan Duffy
    Participant
    This reply has been marked as private.
    #13620

    Alan Duffy
    Participant

    Just wondering if you had a chance to login and see the issues for yourself yet?

    Thanks, Alan

    #13621

    Bartosz
    Keymaster

    Hi Alan,
    We do know what’s going on and why. The prettyPhoto is being used along lightgallery and there seems to be no option to disable it in your theme.

    The responsible piece of code is located in bridge theme folder/js/default.js and default.min.js

    We’ve already adjusted the two files mentioned above on the dev site, but don’t see a way to access and test it. So I suggest you to copy and replace these two js files from dev to live site and check the difference (but please make a backup of the original files just in case)

    Waiting for your feedback.

    #13695

    Alan Duffy
    Participant

    Well the problem is the Visual Composer plugin, not the theme. I tried other lightbox plugins and they have the same conflict problems. Visual Composer uses prettyPhoto and I think they override other plugins on purpose so that you have to use their plugin. I’ll just have to disable your plugin and use the gallery options in Visual Composer.

    Thanks anyway. Alan

    #23253

    Tommy Cordova
    Participant

    So, I have this same problem. My theme also uses Visual Composer. Has anyone come up with a solution for this?

    #30862

    florenzo
    Participant

    having same issue. how can it fix it?

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.