PHP 7.2 compatibility

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29585

    IAR
    Participant

    Hey

    I would like to know if the Download attachments wordpress plugin is compatible with PHP 7.2.
    I’m currently running WordPress 4.5.15 on PHP 5.6 and my host has warned me they will soon update to PHP 7.2.

    I ran the PHP Compatibility Checker and it gave me the following:

    FILE: /customers/c/f/1/domain.org/httpd.www/domainweb/wp-content/plugins/download-attachments/includes/functions.php
    ———————————————————————————————————————————————————
    FOUND 25 ERRORS AND 1 WARNING AFFECTING 8 LINES
    ———————————————————————————————————————————————————
    567 | ERROR | Function mcrypt_get_key_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    567 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    567 | ERROR | The constant “MCRYPT_BLOWFISH” is deprecated since PHP 7.1 and removed since PHP 7.2
    567 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    568 | ERROR | Function mcrypt_get_iv_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    568 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    568 | ERROR | The constant “MCRYPT_BLOWFISH” is deprecated since PHP 7.1 and removed since PHP 7.2
    568 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    573 | ERROR | Function mcrypt_encrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    573 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    573 | ERROR | The constant “MCRYPT_BLOWFISH” is deprecated since PHP 7.1 and removed since PHP 7.2
    573 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    605 | ERROR | Function mcrypt_get_key_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    605 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    605 | ERROR | The constant “MCRYPT_BLOWFISH” is deprecated since PHP 7.1 and removed since PHP 7.2
    605 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    606 | ERROR | Function mcrypt_get_iv_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    606 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    606 | ERROR | The constant “MCRYPT_BLOWFISH” is deprecated since PHP 7.1 and removed since PHP 7.2
    606 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    611 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    611 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    611 | ERROR | The constant “MCRYPT_BLOWFISH” is deprecated since PHP 7.1 and removed since PHP 7.2
    611 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    721 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    726 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    ———————————————————————————————————————————————————

    Is this ok?

    #29642

    ianlee
    Participant

    I have it working on php 7.1.9 on my pc. All is good except the right-click on image is not disabled. But on my external webserver php 5.5 everything works except that and also the full-size images are not watermarked.

    #30137

    craigivemy
    Participant

    Anyone have an update on this? It clearly isn’t PHP 7.2 compatible, yet PHP 5.6 and 7 end of life has been announced and is just around the corner.

    Are the team going to update this plugin since so many sites will be migrating to PHP 7 given the serious security risks of not doing so (not to mention several hosts including WP Engine rolling out auto updates to PHP 7.2 starting Dec 4th).

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.