Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23924

    Ned Buratovich
    Participant
    This reply has been marked as private.
    #23923

    Ned Buratovich
    Participant

    Problem first noticed on 26-Feb-18, was not present a few days before.

    Symptoms:
    when logged into admin, then clicking either the Plugins or the Updates menu item, the page times out before getting a response. All other menu items respond in less than a second. This happened to me on 4 of my websites hosted on SiteGround.com. I contacted them, the best they could do was modify my .htaccess file to increase the timeout:

    SetEnvIf Request_URI “plugins.php” DynamicTimeout=300
    SetEnvIf Request_URI “update-core.php” DynamicTimeout=300
    SetEnvIf Request_URI “admin-ajax.php” DynamicTimeout=300

    So now, my pages don’t timeout, but they still require a minute or two to do what only took a few seconds the day before. So, I went to isolate the cause myself:

    I cloned one of my malfunctioning sites, put it on the standard Twenty Seventeen v1.4 theme, and eliminated all plugins, until left with only 3:

    Responsive Lightbox v1.7.2
    Justified Gallery v1.0.6
    PhotoSwipe v1.0.6

    The problem is 100% reproducible at https://prettymuch.biz/sites/timeout-test/
    I have created an admin account for you at https://prettymuch.biz/sites/timeout-test/wp-admin/ (login credentials coming in the next private message)

    To reproduce:
    login to wp-admin
    Click any of the dashboard menu items (Posts, Media, Pages, Users, Tools, Settings) and note the instant response.
    Click either Updates or Plugins and wait a minute or two for the page to respond.
    Now, in the Plugins section, deactivate both PhotoSwipe and Justified Gallery (this also will take a minute or two)
    Now, click the Updates or Plugins menu and note the instant response.
    Re-activate either PhotoSwipe or Justified Gallery or both, note that the timeout problem returns.

    #23946

    Bartosz
    Keymaster

    Sure, give us some time to check it.
    We’ll get back to you shortly.

    #24098

    Ned Buratovich
    Participant

    I check in every day to see the resolution on this issue (because “Notify me of follow-up replies via email” doesn’t seem to work) and I noticed something that may be relevant to my timeout problem:

    The dfactory.eu loads slowly and incompletely (many days, the stylesheet does not even load).

    I notice the site is waiting for cdn.dfactory.eu, for 10, 15, even 20 seconds sometimes.

    If the plugins need to access cdn.dfactory.eu, and it takes 20 seconds to respond to a request, that could explain why my dfactory plugins are causing gateway timeouts for my wp-admin.

    #24636

    Ned Buratovich
    Participant

    OK, I’m going to close this problem report. Every few days (for a month), I tested my sites and the problem is solid.

    Today, the problem is gone… on every one of my sites. I’m not sure, it could be because of the core update to 4.9.5

    In any case, I’m taking down the problem demonstration site I built in February.

    #25612

    Bartosz
    Keymaster

    Ned,
    We’ve just fixed the issue on the production site you have created.
    I suggest you update RL to 2.0.4 and Photoswipe to 1.1.1 to check if it’s working fine in official releases.

    Regarding the Photoswipe speed – it’s due to fact that we need to have image size for proper display in lightbox.
    In the recent updates we’ve provided a set of solution to speed it up to the extent possible – you should see a noticable difference.

    Finally the CSS issue on our site – there was an issue with CDN in fact, so we have dropped using the CDN for now. If you force refresh the browser you should have the site working fine.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.