Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #16778

    smooth
    Participant

    Hello,

    I use WP4.7.3 with the newest Version of Impreza Theme, I’m unable to create a Photogallery because I can’t choose Lightbox in the Editor. It only works on a single image. It seems that the native WP gallery overwriten by Impreza. I’ve unchecked all plugins but it won’t work. After that I have choosen an other Theme with all installed plugins and all works fine.
    Is there any Solution for the Impreza Theme?

    bye
    Holger

    #16796

    Bartosz
    Keymaster

    Hi Holger,

    Please send us a temporary admin access to your site (using Private reply).
    We’ll try to fix that issue.

    #16806

    smooth
    Participant
    This reply has been marked as private.
    #16810

    Bartosz
    Keymaster

    Hi Holger,
    We’ve checked your site and there are a couple of issues indeed.

    1. Gallery settings doesn’t get displayed in Add Media – for some reason it’s getting removed by your theme. So the only option to use a specific gallery is to set it’s type in the gallery shortcode: type=”justified”, type=”masonry” etc. as described in the help tab

    2. Even when the gallery is set, the lightbox does not get applied as it gets overriden by the theme’s default lightbox.

    We can definitelly solve the 2nd issue if we have FTP access to your site (we’ll provide you a code snippet so you can use it in other sites with Impreza).

    #16823

    smooth
    Participant
    This reply has been marked as private.
    #16886

    Bartosz
    Keymaster

    Hi again,

    It was tough because of the way Impreza theme is coded but we end up with these:

    1. created a child theme
    2. added style.css and functions.php files
    3. deregistered us-core Javascript file and replaced it with same file in child theme, but with theme lightbox disabled
    4. replaced gallery and us_gallery shortcodes with a gallery using RL HTML syntax

    you can test it here http://hss3.de/2017/04/03/test/

    #16917

    smooth
    Participant

    Hi Bartosz,

    great job, Thx a lot

    best regards
    Holger

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.