Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #8975
    Bart van Eijden
    Participant

    Hello,

    my justified gallery stopped working, though I believe I never changed anything. Here is one article with two justified galleries in it:

    http://www.offbeattravelling.com/afghans-in-athens/

    How can I fix this?

    Greets

    #8984
    Bartosz
    Keymaster

    Hi Bart,

    Can you do one quick test – disable Justified Gallery for one of the galleries you have on this page. You have 2 currently, please make only one – we’ll see if that’s the bug with multiple justified galleries on same page.

    #8989
    Bart van Eijden
    Participant

    It didn’t change anything.

    The justified galleries were always working on my article, even with two. Now they don’t, even though I never changed anything.

    I was (successfully) targeting #div.justified-gallery before to change a bottom-margin, but that seems to be gone now. It has now become #div.rl-gallery.

    #8997
    Bartosz
    Keymaster

    Bart,

    Did you update, install, activate any plugins or theme code recently?

    It looks like the javascript code for the Justified Gallery is in conflict – it doesn’t get fired.

    #9072
    Bart van Eijden
    Participant

    I don’t think I updated anything.

    I just dectivated both lightbox as justified gallery and re-activated, but still same problem remains.

    #9073
    Bart van Eijden
    Participant

    Found the problem: it’s in the plugin Yoast SEO.

    It has to do with the Twitter card meta data check box. I unchecked the box and the justified gallery seems to work again. Not sure why, but I will leave it unchecked and find a different way to get the twitter cards working for my site.

    #9099
    Bartosz
    Keymaster

    Very strange. We’ll be looking into this issue.
    Thx for the feedback Bart.

    #9140
    Shaun Nixon
    Participant

    I also had this issue… and a huge THANK YOU Bart – it was indeed the yoast twitter card option. I unticked it and suddenly all of my justified galleries started working again. Good investigation and thanks for sharing, you have saved me a huge headache.

    Shaun

    #10003
    Bart van Eijden
    Participant

    Hi Bartosz,

    did you already find a solution to this problem?

    Greets Bart

    #10029
    Bartosz
    Keymaster

    Yes,

    This is due to the way Yoast SEO works. But fter we release a Justified Gallery update to 1.0.1 (soon) it will work if you set scripts position in Responsive Lightbox settings to footer (usually should be set like this).

    #10030
    Bart van Eijden
    Participant

    I am looking forward to that update then.

    I see there is also an option to set all the lightbox scripts in the footer (‘loading place’ under the ‘general settings’ tab). Since that doesn’t solve the solution at the moment, I assume these scripts are not related to the justified gallery?

    #10031
    Bartosz
    Keymaster

    Nope.

    Yoast SEO calls a gallery in a class constructor, and somehow interacts with the shortcode and the enqueued Justified Gallery script. Puting that info footer solves the issue (and also does not block rendering of a page).

    So, it’s a generally good solution.

    ps. if you’d like we’d send you a dev version in a reply if you contact us via contact form.

    #10153
    stegen
    Participant

    Hi all,
    I’m having sort of the same issue with my site, both with galleries in blog posts and in pages, like this: http://www.stefanogennaro.com/rumore/
    It looks like justified galleries added some strange margins to images. It was perfectly working till my last update, so I don’t know whether is the theme or the plugin update. Any suggestions?
    Thanks in advance!

    #10190
    Stefan
    Participant

    Hi,

    I had the same issue and fixed it with custom CSS. Here it is:

    /* Remove right margin of photo thumbs */
    .alignright, .alignleft, .aligncenter, .alignnone, .size-auto, .size-full, .size-large, .size-medium, .size-thumbnail{
    max-width: calc(100%);
    }

    You can see it on my website: http://www.sichtreisen.net/en/new-york-city-the-city-whose-visitors-never-sleep/

    Greetings,
    Stefan

    #10249
    stegen
    Participant

    Thanks Stefan, that worked great to me!

    #10526
    Geordie Oxley
    Participant

    I’ve added in the CSS above (since turned it off).
    I’ve changed the loading place to be footer. I’m using Justified 1.00 but the issue is still there while Yoast is on.
    Example
    http://www.fullboost.com.au/fb/index.php/2016/02/18/lexus-lc-500h-hybrid/

    #10528
    Geordie Oxley
    Participant

    OK, here is my issue, the pluign is not updating.

    An error occurred while updating Responsive Lightbox – Justified Gallery: Update package not available.

    EDIT: I manually updated the plugin, issues are solved :)

    #10529
    Bartosz
    Keymaster

    Future updates should work fine now @Geordie.

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.