Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #20503

    Heinz Robert
    Participant

    What I have to do to show pictures behind a link?
    How do I create a hidden gallery, where does the plugin load the images from? From another page or do I need a gallery plugin with a shortcode?

    #20504

    Heinz Robert
    Participant

    Maybe I can put my question more specific.
    I am using Elementor and have 5 images which I like to link to 5 different hidden galleries. Do I link to a specific page where I have created a gallery, or show I put the gallery directly in the text element in Elementor?
    I have done that currently with FooBox, but like to change to your plugin.

    #20505

    Bartosz
    Keymaster

    Hi,
    To use the Hidden gallery go to your post edit screen and use the Add Media button.
    Then create a regular WordPress gallery – select the images from Media Library. While adding a gallery you will have an option – Gallery type, added by Hidden Gallery (and our other gallery addons – if you have them).
    In result you’ll have a gallery shortcode with th id’s of images,

    In the post edit screen please have a look at the help tab (upper right corner) as there are additional shortcode parameters described there, or just setup your default settings in RL Gallery tab.

    Hope this helps

    #20519

    Heinz Robert
    Participant

    What if I have more than one galleries on one page/post, will the link show all the pictures or can I link to one specific gallery?

    #20520

    Heinz Robert
    Participant

    And than how to link an image to the gallery? I can’t link to a shortcode. Do I link to the first image of the gallery?

    #20521

    Heinz Robert
    Participant

    I have setup a post with a hidden gallery but with click on the thumbnail it only opens the bigger version of it, not to the gallery.
    [gallery thumbnail="264" mode="image" type="hidden" show_title="0" ids="22,23,30,29,28,27,26,25,24,31,32,33,34,35,36,37"]

    #20522

    Bartosz
    Keymaster

    Your syntax is fine and the gallery shortcode is fine as well.
    It can’t work however as lightbox is not working on this page because of the javascript error:

    TypeError: i(…).offset(…) is undefined 1 main.min.js:1:4349

    If you fix that it should display the gallery in a lightbox.

    #20569

    Heinz Robert
    Participant

    I tried different things from deactivating all other Lightbox possibilities (Jetpack, FooBox) and also deactivate a javascript snippet I use for the parallax effect in Elementor. All did not change the issue.
    Any hints how to find the cause for this error? Where have you found it.

    By the way I don’t get emails when you respond to the post even I have clicked the box at “Notify me of follow-up replies via email”.!

    #20570

    Bartosz
    Keymaster

    In the main.min.js file – but might be related to other issues.

    Can you provide admin access to your site – we’ll have a look.

    Regarding the email notifications – can you check your spam/trash folder? It’s definitelly sent.

    #20652

    Heinz Robert
    Participant

    Hi, did you receive my last private message with the admin link?

    #20682

    Bartosz
    Keymaster

    Hi,
    Nope, we have not received anything – will check that.

    #20683

    Bartosz
    Keymaster
    This reply has been marked as private.
    #20686

    Heinz Robert
    Participant

    Got the private message!

    I got the plugin running.
    One more question: Is there a possibility to hide the thumbnail in the slideshow?

    #20774

    Heinz Robert
    Participant

    Any idea how to hide the thumbnail picture from the slideshow?

    #20789

    Bartosz
    Keymaster

    Trying to help you with that we’ve just added a Hidden Gallery section to documentation – hope this helps https://dfactory.eu/docs/responsive-lightbox/hidden-gallery/

    #20790

    Heinz Robert
    Participant

    That’s great, its a good documentation!
    Anyhow I see the image I load with thumbnail=”” and it shows up in the slideshow. How can I get rid of it? Did not find that in the documentation.

    #20801

    Bartosz
    Keymaster

    Do I understand you correctly – you’d like to have thumbnail removed from the set of images in gallery?

    Well, we haven’t thought of an option like that – whenever you have a gallery there is a thumbnail representation of the larger image. The logic is the same in this case.

    #20851

    Heinz Robert
    Participant

    You understand right.
    So what’s the purpose of the thumbnail=”” code than, if I could also just take the first image of the gallery instead?

    All thumbnails except the thumbnail image under the slideshow are missing. Is that caused by the hidden gallery?
    I did not get any response on my other post and I might not be the only one having that issue.

    #20963

    Bartosz
    Keymaster

    The purpose of this is to select an image to be used as a gallery trigger.
    But this is still a part of the gallery, not a separate thing.

    All the other image links are hidden, but available in HTML so that lightbox scripts can use it – and this is done by Hidden Gallery.

    #26423

    Konstantin
    Participant

    Hello! I’m also using Elementor.
    Could you explain, how to insert shortcode with hidden gallery into image?

    #26425

    Konstantin
    Participant

    I want to open different galleries by clicking separate images on page.
    How to put link to gallery in them?

    #31739

    Bartosz
    Keymaster

    Just go to Galleries and create a new gallery (or modify existing).
    Click Config tab, set the Gallery type to Hidden and find Mode option.
    There you can either chose between Text or Image.
    If you set it as Image a featured gallery image will be used as the gallery link.
    If you select Text the text string you enter will be used as the gallery link.
    Then just use the gallery shortcode in your page/post content or a function in the theme files.

Viewing 22 posts - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.