Tagged: , , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2958

    Gerlando Lo Savio
    Participant

    I tried adding both title, alt text, descripion text and caption, but still can’t see any text on Swipebox for my photos. After I tried with my Swipebox, I’ve tried with different lightbox scripts.

    Only using PrettyPhoto I see some text on the image, but it’s only the alternative text and not the title neither the caption.

    I’m using Responsive Lightbox plugin running also Carousel from Jetpack plugin, and installed Responsive Lightbox to get a lightbox effect that works for single images, since Carousel works only for galleries.

    How do I need to configure this plugin to display the title or the caption together with the image?

    Here’s a link to a page in my test blog, with an image for you to test:
    http://gerloseye.org/it/2014/02/act-without-doing/

    I’m running WP 3.8.1 with a slightly customized Twenty Fourteen theme. Not sure if it may be related, but on this blog I’m running also the Polylang plugin.

    This question was already posted here in WP Support forums:
    http://wordpress.org/support/topic/cant-see-any-caption-or-title?replies=3#post-5232194

    #2959

    Bartosz
    Keymaster

    Hi Gerlando,

    I looked at your site and the problem is not it the plugin but in your theme. Basically, image links in your theme do not contain title attributes.

    For all the scripts lightbox title is taken from the link title, not from image title, alt or anything else. It’s a very flexible solution because lightbox can be used for more content types, not only images. More, you can easilly modify your theme to generate lightbox title form anything you need – post title, custom fields, etc.

    So, returning to your question – you can add link title when you insert image link into post, or modify the theme to automatically use image title/alt/caption as link title.

    Hope this helps.

    #2960

    Gerlando Lo Savio
    Participant

    Thanks, I saw that manually adding the title attribute to link code solves my problem.

    So now I need to find a way to change my theme to do as you say. I suppose I should do it in my theme’s functions.php file. I’ll google for it.

    Can you point me some more detail please? I’m quite new with wordpress, and still don’t know where to look to do some things.

    #2961

    Bartosz
    Keymaster

    Not functions.php but any place in your theme code where image links are created (like single.php) – however all this is theme specific.

    #3137

    Pablo P
    Participant

    Hi, I have the same problem but with galleries, my theme shows the caption of the image on the thumbnail view but when I click it to open the lightbox it just disappears. I don’t know where does the theme generates the title attribute, so, is there a way that I can use the “wp-caption-text” class (where WordPress renders the title) to show it on the lightbox as a caption?

    I’m using the latest version of wordpress and the plugin, also setting it as Fancybox, and using the “Simon WP Framework” as a theme.

    Thanks in advance

    #3146

    Bartosz
    Keymaster

    Pablo, please post a separate topic on that and provide a link to your site.

    #24327

    macchina
    Participant

    Hi,
    I have the same (or similar) problem… No image title, description, etc. in the lightbox.
    I am using:
    Theme: Oria
    Plugins: Metaslider, Metaslider Lightbox, Responsive Lightbox
    My site: http://www.oe3ide.com

    Thanks for help!
    Ernst

    #27686

    CButler
    Participant

    I cant get the title to show in the lightbox on a phone screen. It shows on a computer screen (when you click on the image) but doesn’t show on a phone.
    I’m using responsive lightbox & gallery plug-in.

    #30728

    Phil Brouwer
    Participant

    I am having this problem currently. I am unable to get caption or title to show in Lightbox unless I enable the title or caption on the gallery. If I deselect the captioning in the gallery, the text does not show in Lightbox individual image view. Please advise. I have looked extensively at all my settings and plugins to find any conflict…but I have been unable to get this to work.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.